Forum Posts

az
Apr 29, 2019
In General BMW Discussions
My coil connectors have a slot at the bottom that engages with a tab on the coil. The original slots were offset from the center and they matched the coils on the engine. New coils have a tab that is dead center. Dealer is scratching his head. Even with the correct VIN the centered tab coils is what the parts book calls (and they don't have the offset type), but they won't fit my connectors without modifying either the connector or the coil. What gives? Is there any difference? Why are mine offset? '06 530 Xi.
0
3
380
az
Apr 29, 2019
In General BMW Discussions
How can I back trace the VIN from an engine number? The Dealer said they don't have the capability to do that. I replaced my original N52 engine with a used one from a year newer. When I order parts they want a VIN number and I want to get the correct VIN from the car the used engine came from. How can I do that?
0
1
23
az
Apr 29, 2019
In General BMW Discussions
I replaced the engine in my 06 with an 07 N52. It runs but with a bunch of error codes. Original engine ran without any codes. Replaced it due to scored cylinder wall, low compression. Takes about 3 to 5 seconds of cranking to start but runs smoothly. Many codes seem to point to a crank sensor. Also shows trans error so it only runs in 2nd gear. Replaced crank sensor with BMW official sensor. NO change. Loosened crank sensor to see if that would change anything. It ran pretty roughly with crank sensor loose so it apparently is getting a crank sensor signal. Tightened it up again, back to the same issue. Scan tool shows 2 rpm readings, both within 40 rpm of each other. Intermittently the dash tach will blip down 200 to 400 rpm at speed (2000 to 4000 rpm) I've been trying to find if there are any differences between the two model year engines but BMW dealer said all N52s are the same. Is it possible that the crank sensor gear is different between the two years so the DME and ECU are confused? 07 engine on an 06 DME / ECU?
0
5
56

az

More actions